PROCESSED Question about collisions

Sulps

Goldpot Hunter of the Year | 2019
VIP
This isn't really a help request or a bug report, just a question about SAMP.
Over the last few weeks, I've noticed some players collide with me in races. The catch is that the races have collisions off and everyone else can freely move inside each other. For example, me and several other players are waiting for the race to start, our cars overlapping. But then another player drives into our cars and instantly stops as soon as the cars "collide". Or there's a player waiting for the race to start and I drive into their car. Their car is thrown away at an alarming speed while mine casually drives into the optimal starting position. I've never seen this kind of behavior before and none of those affected have explained anything to me.

So my question is this: why do the cars of a small specific group of players collide in races?

The only explanation I can think of is these players having a mod that causes collisions where they shouldn't happen. So in a way, everyone else has collisions disabled, but these players have collisions enabled. That causes the dragging mechanic, similar to what Bear showed here. But I could be way off, so I'd like to know what the real reason is and whether I'm causing it myself.
 

s0ulreaper

VIP
Former Staff
My guess would be due to ping. Maybe having an implementation to making vehicles nonsolid each three or five seconds before the race starts the countdown? I usually can collide Central American players (since they usually have high ping, inconsistent connection, or both) whilst my collisions are off. That's my observation, YMMV.
 

adlude

Server Owner
The reason for this is the unofficially supported mobile client. In the past months, we've seen a surge in the number of these users. Unfortunately, the mobile client is missing core functions/code and this is why we're seeing glitches like this.
 

s0ulreaper

VIP
Former Staff
The reason for this is the unofficially supported mobile client. In the past months, we've seen a surge in the number of these users. Unfortunately, the mobile client is missing core functions/code and this is why we're seeing glitches like this.
That makes sense. Since the server cannot read FPS from mobile clients, wouldn't it be possible to automatically set them to a virtual world if FPS is less than 1? That would've been my quick and dirty solution...
 
Last edited:

ellie

Web Developer
Head Admin
VIP
That makes sense. Since the server cannot read FPS from mobile clients, wouldn't it be possible to automatically set them to a virtual world if FPS is less than 1? That would've been my quick and dirty solution...
Even if there's a more complex way of doing it, this could be a work around for the time being.
 

Sulps

Goldpot Hunter of the Year | 2019
VIP
The reason for this is the unofficially supported mobile client. In the past months, we've seen a surge in the number of these users. Unfortunately, the mobile client is missing core functions/code and this is why we're seeing glitches like this.
This seems like a reasonable explanation. Thanks, adlude!
If nobody else has anything to add, you can consider my question answered.
 
Top